I can't see webpart in the gallery..

Mar 27, 2012 at 9:48 AM
Edited Mar 27, 2012 at 9:48 AM

.. Feature is activated 

and I have found this in the logs:

Error parsing manifest.xml SafeControl entry's Assembly attribute in solution devskydbconnectwp.wsp. The Assembly name doesn't match the the parent Assembly tag. SafeControlEntry: <SafeControl Assembly="DevSky.SharePoint.Core" Namespace="DevSky.SharePoint.Core.Controls" TypeName="*" xmlns="http://schemas.microsoft.com/sharepoint/" />.  

Is this a possbile cause of the problem?

Mar 28, 2012 at 10:22 AM

Hello,

how did you install the webparts? Did you use the prepared wsp-Package? Please check your safecontrols entries, after installation the web.config should contains the following new entries:

<SafeControl Assembly="DevSky.SharePoint.Core, Version=1.0.0.0, Culture=neutral, PublicKeyToken=a16765135db48a02" Namespace="DevSky.SharePoint.Core.Controls" TypeName="*" Safe="True" SafeAgainstScript="False"

/>

<SafeControl Assembly="DevSky.WebParts.DBConnectWP, Version=1.0.0.0, Culture=neutral, PublicKeyToken=a16765135db48a02" Namespace="DevSky.WebParts" TypeName="*" Safe="True" SafeAgainstScript="False" 

/>

 

Apr 5, 2012 at 6:27 PM

I installed the webpart into SharePoint Foundation 2010 with PowerShell as detailed at http://www.dotnetmafia.com/blogs/dotnettipoftheday/archive/2009/12/02/adding-and-deploying-solutions-with-powershell-in-sharepoint-2010.aspx. In Central Admin | Solution Management it's listed as deployed to the appropriate web site. At the appropriate web site in Site Settings | Site collection features it's listed as Active. But it does not appear in the Web Part Gallery. I don't see any DevSky errors in the logs. I do find:

04/05/2012 13:24:32.99     w3wp.exe (0x4A98)                           0x2960    SharePoint Foundation             Monitoring                        nasq    Medium      Entering monitored scope (Request (GET:http://bptc-server:10197/_admin/SolutionStatus.aspx?ItemName=devskydbconnectwp%2Ewsp&Lcid=0))     
04/05/2012 13:24:32.99     w3wp.exe (0x4A98)                           0x2960    SharePoint Foundation             Logging Correlation Data          xmnv    Medium      Name=Request (GET:http://bptc-server:10197/_admin/SolutionStatus.aspx?ItemName=devskydbconnectwp%2Ewsp&Lcid=0)    08d6a262-c97e-40ba-996a-d8ce3c73010f
Any ideas?

Apr 24, 2012 at 2:46 PM

I have exactly the same problem.

The necessary safecontrol entries are in the web.config, but the webpart itself is not in the gallery. Tried a IIsreset but with no effect.

Aug 10, 2012 at 8:46 AM

I have exactly the same problem. Any solution ?

Aug 17, 2012 at 7:49 AM

Problem is solved in Version 0.2 (Download: SharePoint DataBase Web Part - (Verson 0.2))

Oct 1, 2012 at 4:34 PM

Took me quite a while to get around to testing this, but 0.2 has the same problem for me.